RedHatInstallAmanda

How to install Amanda on Red Hat

PLEASE NOTE: This is for Amanda running on Red Hat Enterprise 5 x86-64. This could apply to other versions. Or not.

Order in which to install the RPMs

The only difficulty in the Amanda installation is that Red Hat has split this software into multiple sub-packages, with complex dependency relationships. Some packages won't install unless others are already installed, etc...

So here is the order in which they should be installed:

  1. amanda-2.5.0p2-4.x86_64.rpm
  2. gnuplot-4.0.0-12.x86_64.rpm
  3. amanda-client-2.5.0p2-4.x86_64.rpm
  4. amanda-server-2.5.0p2-4.x86_64.rpm

Follow this order, and Amanda should be installed without any problems! (Hopefully...) Please note that the version/subversion numbers could, of course, be different in your version of Red Hat Enterprise Server.

Please note that gnuplot-4.0.0-12.x86_64.rpm is required by amanda-server-2.5.0p2-4.x86_64.rpm and should be installed as well.

Which says a lot about the packing too many functions in a package. That's Red Hat for you.

See Also: